Erzbohrer Radfahrzeug

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Erzbohrer Radfahrzeug

      Hallo Space-Engineerfans.

      So, nun muss ich doch Fragen stellen weil ich nicht mehr weiter weiß. Ich spiele im Überlebensmodus auf einem erdähnlichen Planeten.

      Ich habe mir einen Erzboher (Testfahrzeug) gebaut, mit dem ich vertikal bohren kann. Alle bisherigen Flugbohrer, die ich bisher baute, sind irgendwann beschädigt worden, ohne dass ich je den Erzflöz erreicht hatte. Also musste nun ein Radfahrzeug her. Mit vier Achsen (Räder 3x3) , vorne drei Hub- Kolben mit zwei Bohrern. Danach kommen vier Akkus und sechs Mittleren Frachtkontainer, und zum Schluss der Steineauswurf, inkl. Förderband, Verteiler, etc. Also ähnlich wie es in einigen YouTube Videos gezeigt wird.

      Das Fahrzeug lässt sich gut steuern und fahren. Wenn ich nun langsam im Stand bohre und die Kolben senke, bzw. ausfahre, beginnt irgendwann sich der Boden unter den Bohrern abzusenken und die Verbinder mit dem Steinauswurf. Soweit so gut, das haben alle Fahrzeuge in den YouTube Videos auch getan.

      Als letzte Modifikation an meinem Bohrfahrzeug habe ich vorne rechts und links je eine ausfahrbare Stütze montiert, wie man es von Schwerlastkränen her kennt. Mehrere Versuche waren einwandfrei (ohne Bohren)

      Aber selbst nun mit der letzten Modifikation, beginnt irgendwann das ganze Fahrzeug noch vorne über die ausgefahrenen Stützen zu kippen, und fängt an wie eine Ballerina, Pirouetten auf den Stützbeinen (soweit noch vorhanden) zu drehen. Springt auf, überschlägt sich etc. Aber nicht einmal, nein, fast unendlich!

      Den gleichen Vorgang hab eich mit und ohne und sogar mit zwei Gyroskopen ausprobiert, es passiert immer das gleiche.
      Wenn ich weiß, wie ich aus dem Game heraus Screenshots machen kann, lade ich gerne Fotos hoch.

      Wer kann mir helfen und kennt das Problem?

      Ich habe für heute mal genug :cursing: und spiele lieber Anno1800
    • Screenshots mit F10 - zu finden dann im lokalen Space Engineers Ordner des Benutzerverzeichnisses.

      Zu dem Thema Subgrids, Rotoren + Kolben und den sogenannten Phantomkräften hat Splitsie auf YT ein ausgezeichnetes Erklärvideo gemacht
      unter welchen Umständen diese auftreten und warum etc. (das Beste, was ich bisher dazu kenne) leider nur auf Englisch.

      ->

      Im Prinzip ist es so:

      da auf deinem Gefährt der Bohrer auf einem ausfahrbaren Kolben sitzt, ist dieser auf einem Subgrid für welches ein separater Schwerpunkt berechnet wird. schaltet sich der Bohrer ein wird nebenbei auch ein Schütteln des Bohrers simuliert (die Option toolshake - kann man auch abschalten) ist der Bohrer noch leer, mag sich der Effekt noch nicht so schnell auswirken. Füllt er sich dann so nach und nach mit Material,
      erhöht sich die Masse und damit der Impact. -> Schwingungen bauen sich auf. Durch das zufügen von Stützbeinen
      (ich vermute mal ebenso auf Kolben) wird das ganze nicht besser, da diese ebenso auf Subgrids sitzen
      und damit noch mehr eigene Schwerpunkte simuliert werden.
      Würde mich nicht überaschen wenn's am Ende noch mehr wobbelt.

      Du hast die Möglichkeit durch die Option "share internal tensor" eine Berechnung eines gemeinsamen Schwerpunkts zu erzwingen,
      wie im Video gezeigt. Nebenwirkung: sämtlicher möglicher Impact /Damage betrifft nun das gesamte Grid, daher ist diese Möglichkeit
      mit bedacht zu wählen.

      Auch wichtig wäre zu wissen, ob du auf einem Server im Multiplayer spielst, denn da kommt zusätzlich noch hinzu
      dass die Physik-Engine besagte simulierte Schwingungen mit Server/Client synchronisieren muss.

      Ganz nebenbei:

      Auch in der Realität ist der Aufbau von Eigenschwingungen ein nicht zu unterschätzendes Problem, manchmal gar nicht so leicht zu handeln.
      Wenn nun simulierte Physik versucht, dieselben Effekte nachzubilden, kommen manchmal die tollsten Sachen dabei raus.

      Ob Kerbal Space Programm, Space Engineers etc... jede simulierte Physik struggelt damit, die eine mehr, die andere weniger...

      Übrigens, die Videos von Splitsie sind für Space Engineers sehr zu empfehlen. Und unterhaltsam sind sie nebenbei auch noch...
    • Hi, und Danke für die schnelle einfache Antwort.
      Ich spiele im SP Modus. Erst wen ich mal Erfahrungen mit Bauen, Sammeln, etc. habe, wende ich mich vielleicht MP zu.

      Es ist schade, dass die Berechnungen so schwirig sind. In den Videos sieht alle einfach aus. Da muss ich mir doch gleich das Video anschauen.

      Grüße Jürgen :D

      Nachtrag: Habe mir das Video angeschaut und bei mir getestet. Selbst wenn ich "Share inertia tensor" eingeschaltet hatte, gab es Ballerina Pirouetten. :( ;)
      Ich habe mir daraufhin mein Fahrzeug mal genauer angeschaut und dabei bemerkt, dass die Förderbänder gleich am nächsten Block, also direkt am Kolben nach oben führen.
      Im Video wird gezeigt, welche Auswirkungen das hat.

      Also Förderband verlegt, und es hat funktioniert. Jedoch habe ich das Fahrzeug stillgelegt, weil die Bohrtiefe nicht ausreicht, nicht mal für Eisenerz.

      Ich müsste so viele Kolben vorne anbringen, das es noch Kopflastiger wird. Oder gleich ein Großes Fahrzeug mit großen Blöcken bauen.

      Nun habe ich vorerst meine Förderanlage von der Basis zum Erzlager ca. 1km verlängert. nun muss ich nicht dauernd ein Fahrzeug nehmen. Verbinder dran und schürfen.
      Wie ich das bei den abgelegenen Erzvorkommen mache, weiß ich noch nicht. hab ja noch Zeit.

      Grüße Jürgen

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von hobbiter_1 ()

    • Danke, dass du Feedback gibst, auch nicht mehr selbstverständlich heutzutage.

      Zumindest weisst du nun was los ist, wenn Ballerinas in Space Engineers Pirouetten hinlegen :whistling:
      Die Erkenntnis wird dir sicherlich bei zukünftigen Konstrukten helfen.

      Übrigens gibt es da auch noch seltsame Phänomene bei anderen Sachen, die noch nicht erwähnt wurden.
      Die Anzugskräfte der Verbinder können beispielsweise die tollsten Sachen bewirken,
      aber das "spoiler" ich jetzt nicht, möchte doch niemandem das einmalige "Clang"-Erlebnis versauen :D
    • Ach ja, dann hab ich wohl als einziger das Problem es nicht zum laufen zu bringen!

      Im Baumodus funktioniert es einwandfrei, auch ohne Zeitschaltuhr.

      Im Überlebensmodus funktioniert es einfach nicht. Ich kann alles einstellen und anzeigen lassen was im LCD Display so geht, auch jetzt nach dem Update, aber beim Script steht immer nur online. Hab es schon rausgeschmissen, neu geladen und die verschiedenen Video auf YouTube angeschaut und sogar alles was wichtig sein könnte auf einem Zettel genau notiert, damit ich ja nix falsch mache oder vergesse, nix!
    • hobbiter_1 schrieb:

      [...]Im Überlebensmodus funktioniert es einfach nicht. Ich kann alles einstellen und anzeigen lassen was im LCD Display so geht, auch jetzt nach dem Update, aber beim Script steht immer nur online. Hab es schon rausgeschmissen, neu geladen und die verschiedenen Video auf YouTube angeschaut und sogar alles was wichtig sein könnte auf einem Zettel genau notiert, damit ich ja nix falsch mache oder vergesse, nix!
      • Kann es sein, dass dein Bildschirm nicht im Text-Anzeige-Modus, sondern im Bild-Modus ist?

      • Ansonsten: Der genutzte Bildschrim muss im Namen [LCD] stehen haben
      • Die Inhalten gehören in "Custom Data" (bei alten Videos wird gerne noch das Titelfeld verwendet)
      Former Councelor of the United Factions Space Council (R.I.P.)
      Architect of the Orion Tech Syndicate
      Mastermind of future empires

      "He who stays in the footsteps of others cannot improve."

      ______________________________________________________________________________________________________
    • Alles schon ausprobiert, alle möglichen Modi, und im reinen Baugame funktioniert es ja auch, genau so wie in den Youtube Videos. Bei mir steht aber nur online.
      Ich dachte erst, es liegt an den Update vom Game, aber ich habe hier und auf anderen Seiten nichts diesbezüglich darüber gefunden. Auch beim Befehle "Code überprüfen" erscheint auch keine Fehlermeldung.

      Nach dieser Anleitung hab ich es das erste Mal ausprobiert und im Baugame/-Modus hats auf anhieb funktioniert. Nicht aber im Überlebensmodus/-game

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von hobbiter_1 ()

    • Um das Thema nochmal aufzugreifen:

      Habe gestern bei meinem ersten Ausflug in MP (ich war alleine, also gut zum Ausprobieren der Physik) einen kleinen, stabilen, gut fahrbaren Buggy mit einer Bohrvorrichtung am Heck ausstatten wollen. Bis zu den Bohrern bin ich aber gar nicht mehr gekommen. Als ich auf den einen vertikalen Kolben, den ich dachte nutzen zu können (komm schon, ein Kolben geht bestimmt), ein Förderband aufsetzte, wo dann ein oder zwei Bohrer dran sollten, sprang der Buggy los. Wie ein Gummiball! Hab ihn paar hundert Meter später wieder einfangen können. Stark beschädigt und auf dem Dach liegend.

      Mal im Ernst, wenn die Berechnung der Physik so kompliziert und fehlerbehaftet ist, dass man diese Komponenten im MP (aber auch teilweise im SP) quasi nicht nutzen kann (und damit einen wichtigen Teil des Spiels), dann sollte man die Physik da abschalten. Das läuft für mich irgendwie unter der Rubrik: "Kann man so machen, aber dann ist es halt scheisse!".
      In den Vidos vom Startbildschirm sieht alles so toll aus... Naja, ist wie Werbung. Ist nie das drin, was sie verspricht...

      Aber als Ingenieur nimmt man sowas ja gelassen. Den Buggy mit Schubdüsen wieder auf die Räder zu stellen war ein Spaß!
      Ihn danach in einen Schweber umzubauen allerdings wieder nicht. Die Flugphysik und die Turbinen funktionierten nämlich auch nicht richtig. Mal ja, mal nein, mal komplett seltsam (warum fliegt mein Gefährt in eine Richtung, wenn ich in jede Richtung eine Düse habe und er nur auf der Stelle schweben soll und in keine Richtung geneigt ist? Ich hab das Ding fliegen müssen wie einen Hubschrauber, also mit Neigung des ganzen Gefährts, weil nur die vier Aufwärtsdüsen genug Schub lieferten, um die Eigenbewegung des Dings zu kompensieren. Vielleicht war auch grad viel Wind auf dem Mars... wer weiß). Und später sprang das Teil immer auf den Boden und wieder in die Luft, obwohl es eigentlich nur auf der Stelle schweben sollte (wenigstens ohne Schaden zu nehmen, zumindest war dieser Fehler so fair und hat mir den Flieger nicht geschrottet). Eigentlich war ich dankbar, weil ich, da selbst ein einfaches Fluggerät nicht tat, was es sollte, irgendwann keine Lust mehr hatte und früh ins Bett gehen konnte. Aber ich schwenke grad vom Thema ab. Es ging ja um Bohrer....
    • Hi und Danke, dass das du mir helfen willst. Habe die Hoffnung schon begraben.
      Habe gerade nochmal nachgeschaut wie die Einstellungen bei mir sind.

      Experimental mod: aktiviert
      In-game Scripte: aktiviert
      Programierbarer Block: bei Custem Data steht nix; bei Bearbeiten steht das Script "Automatic LCDs2" (v:2.0168 (1.190 compatibility........)
      - Code prüfen: Meldung "Kompilieren erfolgreich"
      - Content steht auf Script
      - bei Script steht None
      - gehe ich auf Ausführen passiert nix!!
      Am LCD Bildschirm steht nur "online"
      Resteinstellungen bzw [], wie im oberen YouTube Video, das ich gepostet habe.

      das Script funktioniert nur im Kreativ Modus (und da einwandfrei), nicht aber im Überleben Modus

      Was mir seltsam erscheint, aber vielleicht ist das normal, gehe ich bei Einstellungen auf Mod, kann ich alle Mods sehen, die ich geladen und aktiviert habe, jedoch nicht das LCD Script. Aber es ist ja im Programmierbaren Block vorhanden.

      Grüße Jürgen
    • Bei mir funktioniert es und ich auch nicht die wirklich große Ahnung:

      1. Script im programmierbaren Block geladen? Hast du gemacht. Check! Die anderen Einstellungen am Block sind Latte, da bin ich gar nicht dran gewesen.
      2. LCD muss im Namen entweder [LCD] oder !LCD! (Ausrufezeichen, extra für die deutschsprachige Tastatur). Wenn du den LCD umbenennst, kannst du drei, vier Sekunden später sehen, wie der LCD in seinem Menü weitere Unterpunkte erhält. Hast du ja auch gemacht. Check!
      3. Im LCD !!!! unter Custom Data musst du jetzt die Befehle eingeben! Also jeden Bildschirm einzeln konfigurieren. Der programmierbare Block führt nur das Script aus und das war's! Mehr macht der nicht und da muss auch nix eingestellt werden. Der Rest läuft alles über die LCD's!

      Z.b. gib im LCD einfach mal PowerStored ein. Oder Inventory. Gibt ja massenweise Befehle, die man auch noch spezifizieren kann.
      Wenn es immer noch nicht läuft, dann hast du wohl doch einfach Pech, was ich mir aber nicht vorstellen kann, weil es eigentlich ein völlig unproblematisches Script ist. Und ich kann das sagen, weil es das erste und einzige Script ist, was ich benutze und immer wenn es nicht lief, lag es an mir. :whistling: :whistling:
      Und ich spiele übrigens nur Survival! :D

      Und Scripte sind keine Mods. Deswegen stehts das auch nicht bei den Mods....

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Voltmeter ()

    • Hi,
      habe gerade nochmal alle Klammern ausprobiert, tut sich nix. Ich denke auch, dass ich irgendwo einen Fehler mache (hoffe es jedenfalls), aber ich verstehe nicht, dass das Script im Kreativ Modus funktioniert, jedoch nicht im Überlebens Modus.

      Auch beim Starten im Programmierbaren Block tut sich nichts, anders als im YouTube Video das Wicking71 empfiehlt, wo das Script rechts abläuft. Aber es kann auch an den verschiedenen Spiel Versionen liegen.

      Hier zwei Screenshots. Weiß aber nicht ob die euch etwas sagen.
    • Bei mir wird rechts nix angezeigt. Im Block läuft bei mir nix ab, aber die LCD's laufen ordnungsgemäß. Daran kann's nicht liegen.

      Aber, was mir aufgefallen ist auf dem Bild des LCD:

      Ändere mal die Fraktionseinstellung! Da steht bei Dir "Nicht teilen". Stelle das mal auf "Mit allen teilen" (oder was da in deutsch auch immer stehen mag) bzw. "Share with faction" für die englisch spielenden.

      Das Gleiche übrigens im progr. Block. Da steht gar nix. Bei mir steht da ebenfalls "Share with faction". Pass' das mal an und ich vermute, dass wir dann das Problem behoben haben. Diese Sache mit den Zugehörigkeiten von Objekten ist in SE manchmal etwas tricky.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Voltmeter ()

    • NIX wars! Zu früh gefreut!!! :(





      Wie man sehen kann, es wird viel angezeigt!! Jedoch ohne Werte. Meine Lager sind aber randvoll, die LCDs zeigen aber nix an!!! Außer "Damage", das funktioniert. ?(


      Gebe ich z.B."PowerSummary {Akkuraum 2}" ein, sollten ja alle Batterien angezeigt werden, bei denen "Akkuraum2" enthalten ist. Aber es kommt die Fehlermeldung, dass nicht mit dem Namen gefunden wird, obwohl ich einen Akkuraum1 und Akkuraum 2 habe mit jeweils 15 Akkus. Name z.B. des ersten Akku: "Batterie 1 Akkuraum 2" (ohne Anführungszeichen). Alle weiteren Akkus dort, zähle ich hoch.


      Ich habe das Script nochmals geladen und gestartet, auch mal das deutsche Script. Allerdings kommt da beim Prüfen mehrere Fehlermeldungen. Angezeigt wird dort außer dem deutschen Bezeichnung der Teile genau so wenig. ?(


      Da habe ich das original Script nochmals geladen und genauer angeschaut. Dabei sind mir (siehe Screenshot) die vielen Rauten mit Fragezeichen aufgefallen (schlecht erkennbar auf dem Screenshot). Darf das sein, ist das bei euch auch so?


      :?: :?: :?: :?: :?: :?: :?:
    • Das, was du in deinem Screenshot siehst, ist ein Codierungsproblemm zwischen Ascii und UTF-8.

      Hast du das Script direkt über "Browse Scripts" oder via Copy-Paste eingefügt? In letzterem Fall hatte dein Text-Editor, mit dem du das Skript vor dem Kopieren wohl geöffnet hattest, die falsche Schriftcodierung aktiv, was sich dann so darstellt. War das Script dagegen direkt aus dem Workshop, hat Keen mal wieder saubere Arbeit geleistet...
      Former Councelor of the United Factions Space Council (R.I.P.)
      Architect of the Orion Tech Syndicate
      Mastermind of future empires

      "He who stays in the footsteps of others cannot improve."

      ______________________________________________________________________________________________________